Skip to content

Recording guitar in Garageband

February 4, 2009

The LINDY blog has now moved to- http://www.lindy.co.uk/blog/

To view an up to date version of this post & make comments visit- http://www.lindy.co.uk/blog/2009/02/04/recording-guitar-in-garageband/

 

If you’re a guitarist of a certain age like me you probably find computer sequencers and audio recording software pretty difficult to use. Maybe it’s just me, but I struggle with the user interface in Cubase, Logic etc. I just find them too complicated! In the past I’ve spent a small fortune on digital multitrack recorders, FX units and audio software and I never use them! Just give me a Strat and an old Marshall and I know what I’m doing – I mean there are knobs to turn and everything!

Having said all that, there is actually one piece of music software that even I can use – Garageband. The fact that you can drop samples onto tracks and build up songs in a modular fashion makes it pretty much idiot proof. And lets face it, with me it needs to be! However, even though the built in samples in Garageband are fun to play around with, isn’t it much more fun to play a real instrument like a guitar? 

So when I learned from one of our Product Managers at LINDY that we were introducing a USB Guitar cable I thought here’s my chance and I grabbed one from the first delivery to give it a try.

usb-guitar-cable

Anyway, what follows is a quick guide to setting up and using the LINDY USB Guitar cable to record in Garageband…

Here we go!

First of all, what do you need? Well, a Mac with Garageband is essential, a guitar (or bass – we’ll let you bassists play too), knowledge of at least 3 chords is mandatory :-), some speakers (or headphones if the kids are asleep) and the aforementioned LINDY USB Guitar cable, priced at a very reasonable £19.99 ;-).

For this test I used my 1.33GHz G4 Mac Mini which only has a measly 512MB RAM, but thanks to the Core audio drivers built-in to OS X I didn’t have any major latency issues. If you’re interested, for the guitar I used a Fender Classic Player 50s Stratocaster– my favourite at the moment. If you’re looking for a nice, affordable Strat I suggest you check one of these out.

The Technical Stuff

First things first, power up your Mac and plug the cable into a spare USB port. There’s no need for any special drivers – it’s a Mac not a PC, it just works! You can check the USB guitar cable is installed correctly by taking a look at the Sound settings in System Preference:

sound-input-good1

Under the Input tab, make sure C-Media USB Audio Device is highlighted. By the way, you can plug the cable into your guitar now if you like, but you won’t hear anything just yet. There is one important setting to take note of here  – Input Volume. You’ll need to set this quite low to avoid distortion (and not the good kind either). After you’re up and running in Garageband you might need to tweak this setting to get the best sound. I found setting it to about a quarter gave the best results.

Next, take a look at the Output tab. Make sure built-in audio is highlighted, although this can also be selected within Garageband later on:

sound-output

OK, you can close the Sound window now. Next, take a look at Audio MIDI Setup. This can be found in the Applications>Utilities folder:

audio-midi-setup

Select the Audio Devices tab. Make sure the default input is set to C-Media USB Audio Device and both Default Output and System Output are set to Built-in Audio. Close the Audio MIDI Setup window.

Let us ROCK!

Right, now it’s the fun part! Launch Garageband and select the Preferences option under the Garageband menu. (Note: I’m running Garageband version 2.02, your menus may look slightly different). Select Audio/MIDI and make sure the settings are set the same as the example below:

garageband-audio-setup

Close the Preferences window and create a new track: Track>New Track. Make sure Real Instrument is selected and Guitars. You can select one of the example sounds, for example Classic Rock. Now, THIS IS THE IMPORTANT BIT! You must select On next to the Monitor option otherwise you won’t hear anything while you play! So, now you should be hearing something, even if it’s noise (if you don’t hear anything you’ve either got very quiet pickups or you’ve forgot to turn your guitar volume up!):

real-instrument

Now, you can play around with the different amp simulation types, effects settings etc. (you’ll almost definitely want to tinker with the noise gate settings – you’ll probably find your pick ups pretty noisy, especially using distortion sounds), but remember for best results, keep an eye on your input levels! 

More about Latency

That’s about it, but one more note about latency…If you experience latency issues, i.e. where there is a noticeable delay from the time you hit the strings to the sound coming out of the speakers, try this: hit record, wait a few seconds and then press stop. Try playing and, hey presto, the latency should be gone.I found this neat tip on ehow.com, where there’s a whole bunch of Garageband tutorials.

Anyway, hope you find this useful. Now make a record!

Advertisements
43 Comments leave one →
  1. February 10, 2009 12:51 pm

    As of 10th February 2009, we’ve sold out of our stock of the USB guitar cable. I’ll post another comment when it comes back into stock.

  2. March 10, 2009 10:50 am

    This cable is now in stock. Order one now before we run out again! 🙂

  3. Justin permalink
    July 21, 2009 7:21 pm

    Would you know if the usb guitar lead works with Audacity on Vista?

    Cheers
    Justin

  4. July 22, 2009 8:14 am

    Hi Justin

    To be honest, we haven’t tested it with Audacity on Vista, but I can’t see why it wouldn’t work – in effect Windows detects the cable as a separate sound card so I guess it would just need to be selected as the input audio device in Audacity.

    I’ll try and test it myself to see if it works and post the results here.

    MikeO

  5. Ronit Basu permalink
    July 22, 2009 7:18 pm

    I’ve just ordered the guitar usb cable from the website. It cost £19.99! When did it go up by £5?

  6. July 23, 2009 8:16 am

    Sorry – I’m afraid the price had to go up about three weeks ago. I’ve updated the blog entry now to reflect this.

  7. Beth Baker permalink
    August 2, 2009 3:58 am

    Thanks for taking the time to post such clear directions! I googled you up and went from having a frustrated hubby with a “useless d***ed usb cable” to a happy guy; he has GADD (guitar attention deficit disorder) so he hasn’t actually talked to me since he got his setup going, but you should see the happy look on his face. You’re the one who ROCKs.

    BB

  8. August 4, 2009 8:38 am

    Thanks for the kind comments, Beth.

  9. August 4, 2009 8:39 am

    Reagarding using this cable with Audacity in Vista. I’ve asked our Tech department to check and they’ve confirmed it does work.

  10. Nuno permalink
    August 10, 2009 12:49 pm

    Hi

    How many instruments can you have playing simultaneously using these cables as imputs to a pc or mac? Is there a limit?

    Thanks

  11. August 11, 2009 3:52 pm

    Nuno.

    You can only play one instrument at a time. This is because PCs only allow one sound input at a time. Our technical department have never seen software that can pull sound from mulitple sound cards which is effectively what these cables are.

  12. Daniel permalink
    August 13, 2009 1:30 am

    Very cool. I’m a mac user, but I’m more a fan of Logic Studio. Is this compatible? What about the XLR mic to USB cable?

    How many of these can I use at once on a mac?

    What’s the audio quality? I’m not expecting 192khz 24bit audio, but i’d want to record my band with these, so they’d have to be decent.

    Thanks!

  13. August 14, 2009 11:13 am

    Daniel,

    The USB Guitar and USB XLR cables should work with any third party applications that support sound input. So you should be fine using them with Logic Studio. Out Tech guys have only tested using one cable at a time using a Mac. The audio quality is good, certainly good enough for home recording etc….not sure what it is exactly though.

    Thanks

    Craig

  14. Daniel permalink
    August 16, 2009 10:37 am

    Ok thanks for that. Very tempted.

    Can I use it with a USB hub or does it need to be plugged straight into the PC’s M/B USB?

    Don’t suppose there’s any chance someone could test a few at once? If I can record several at once, then I’d by one for my guitar, my bassist would get one, my singer would buy the mic one, and my drummer would by either 1 guitar one, which I presume is ok for an electric drum kit, or 3 mic ones so he can mic his other kit.

    Thanks

  15. Daniel permalink
    August 16, 2009 10:44 am

    Just found this. Any of your techies big on OSX? I think you can use many devices simultaneously, with the latency of your slowest device.

    http://www.apple.com/pro/techniques/aggregateaudio/

  16. August 18, 2009 10:12 am

    Daniel,

    Although we havent tested using multiple cables at the same time, according to our tech department this should work fine when using a Mac. Let us know how you get on Daniel!

    Craig

  17. Daniel permalink
    September 23, 2009 6:04 pm

    Finally got a macbook. So my next question is will these work fine with a usb hub, considering I’ll have several cables plugged in?

    Thanks

  18. September 24, 2009 7:51 am

    Hi Daniel,

    I recommend you plug this cable directly into one of your Macbook’s USB ports rather than a hub. In fact, that goes for any other USB audio devices too. USB hubs are fine for keyboards, printers and scanners etc., but for audio devices they can introduce white noise and glitches.

    Some good info on the Line6 website about this: http://line6.com/community/docs/DOC-4282

    Regards

    MikeO

  19. Gareth permalink
    December 18, 2009 11:57 pm

    Received this today and the sound quality is pretty poor. I’m guessing this is down to my laptop’s sound card, which is an onboard Realtek HD through ASIO4ALL. Being aware of the difficulties related to installing hardware on laptops, I’m wondering what my next course of action should be? Is there any hardware you would recommend or methods I could implement to improve things? This is through ASIO4ALL with Guitar Rig (although I get similarly sterile results through Sound Recorder). Thanks in advance.

  20. December 21, 2009 10:02 am

    Hi Gareth

    I would have thought you’d get pretty good results using Guitar Rig (even with your laptop’s onboard sound). One of our Tech guys uses Guitar Rig with this cable and it’s okay (he is using a desktop PC with a soundblaster live card, though).

    When you say ‘sterile’ results are you getting any ‘effected’ sound at all? For example, are you hearing the guitar as though it was playing through an amp? And, what about latency? Is there any noticeable delay from hitting the strings to when you hear the sound?

    I have an Acer laptop at home. I think it may even have the RealTek audio chipset. Let me give it a try with Guitar Rig and see what kind of results I get, then I’ll get back to you.

    MikeO

  21. Nuno permalink
    December 21, 2009 10:23 am

    What speakers are you using? It could be it i think.

  22. December 22, 2009 12:04 pm

    OK, I tried the cable with Guitar Rig on my laptop last night. It’s an Acer Aspire and the onboard sound chip is RealTek HD.

    I got pretty poor audio ouput via the headphone socket (I was using headphones)- it was crackling and distorting. So I switched to a Line6 Toneport as the audio output with perfect results. So it looked like the RealTek chipset was the problem.

    Anyway, I brought the laptop and guitar into work today and set it up with a good set of PC speakers and the results were great using the onboard sound!? I’m not sure why! I tweaked the latency settings to get good response and I got perfectly acceptable results with little noticeable delay and no break up or distortion.

    I’ll probably test a bit more over the next few days to see if it’s consistent. Meanwhile, I’ve posted the ASIO settings I used here

  23. Jonathan permalink
    January 2, 2010 5:52 pm

    My cable just buzzes like mad even when its not plugged into any device with any effects – I’ve tried it through various USB ports and it still buzzes – I can filter it out using the gate, but should it be that noisy? It reminds me of an old analogue cable with a crack in the lead or something.

  24. January 4, 2010 9:35 am

    Hi Jonathan

    You will get some noise, but it shouldn’t as bad as you’ve described. Are you using a have single coil pickup or a humbucker? Single Coils will typically be noiser than humbuckers.

    What software are you using it with? If you’re using a Mac you can try reducing the Input volume in the Sound Settings of System Preferences – this should help. Let me know how you get on.

    MikeO

  25. Ray permalink
    January 17, 2010 9:46 pm

    Using the cable on a Win PC with Audacity, it records OK but I can’t hear what I am playing, or the backing track. I have to unplug the cable to hear playback as if it’s ‘cutting out’ my speakers

  26. Ray permalink
    January 17, 2010 10:06 pm

    OK – apologies, it’s sorted now.

    If anyone else has a similar problem for some reason best known to itself Win Sound Properties defaulted to the cable for ‘Playback’ !

  27. January 18, 2010 8:51 am

    Hi Ray

    That’s great. Glad it’s all sorted.

    MikeO

  28. Rachel permalink
    January 20, 2010 3:19 pm

    Hi,

    I’ve plugged the cable and guitar into my laptop, the blue light is on, the driver has been installed but Audacity isn’t “seeing” it in the input devices option.

    I’ve downloaded KRISTAL as well, but it’s not great and the speakers won’t work when the cable is plugged in so, all in all, is quite crap.

    Is there anyway of hearing what you are playing at the same time as having the cable plugged in?
    I’m not at all satisfied with this cable, it is not particularly intuitive to use, there are no instructions with it and it’s just frustrating.

  29. January 20, 2010 3:53 pm

    Hi Rachel

    Sorry to hear you’re having problems. We’re going to set up Audacity in our Tech Department tomorrow. Hopefully we’ll get decent results and post some installation / operating instructions for it.

    MikeO

  30. January 21, 2010 8:58 pm

    We’ve tested with Audacity and, to be honest, I wouldn’t recommend using it for recording guitar with the USB cable. This is because it does not easily support low latency ASIO drivers required for decent results.

    Instead I would recommend downloading an evaluation of Reaper. This software is fully functioning and available for trial for 30 days. It supports ASIO drivers and has extensive support documention available too.

    Reaper can be downloaded here: http://www.cockos.com/reaper/

    And ASIO4ALL can be downloaded here: http://www.asio4all.com/

    Also, see my post here which shows the ASIO4ALL settings I used to get decent results using Guitar Rig software:

    https://lindyuk.wordpress.com/2009/12/22/lindy-usb-guitar-cable-realtek-hd-chipset-and-guitar-rig/

  31. Rachel permalink
    January 22, 2010 12:21 pm

    Thanks for the information, Mike! I’ll try that out ASAP.

  32. January 22, 2010 1:23 pm

    No problem. If you have any difficulty getting this setup working, please do let me know. I had this working yesterday at home on a laptop with good results using Reaper and Guitar Rig so I know it works okay. Some of the settings need tweaking to get best results, so I can probably put some screen grabs up if you encounter problems.

    Also, there’s very good documentation for Reaper here:

    http://www.cockos.com/reaper/userguide.php

    …which is worth looking at. Also, if you’re not familiar with ASIO drivers it’s worth reading the instructions on the ASIO4ALL website too.

    PCs eh? It’s all so much easier with a Mac! 🙂

  33. Gareth permalink
    January 22, 2010 2:15 pm

    Hi Mike. The sound was indisputably diabolical on my Toshiba, just very temperamental and noisy. Maybe it was latency – I used to think latency was little more than the speed of response between a device and computer, but turns out that a poor degree of it can seriously warp audio output quality. Or maybe I just didn’t tinker sufficiently with the noise gates (took me a while to figure out what they were, even! – fairly new to this sort of thing).

    Another possibility is, as you mentioned, the headphone output, which I did happen to be using – there is a similar dithering of quality with my amp, which sounds good through the cones but woeful with phones of any kind. But then again, I got a MBP today and the cable works much better in Garageband, and with earphones! So it’s a mystery – unless Apple just happen to manufacture really good headphone ports 😉

    Thanks for going to all that trouble, I do appreciate it. Maybe these comments will be helpful to anyone else having difficulties setting this up.

  34. January 22, 2010 2:25 pm

    Hi Gareth

    Thanks for the feedback! Glad you’ve got it working with your new MBP.

    MikeO

  35. February 1, 2010 3:28 pm

    Please note: We’ve now moved this blog so it’s hosted on the LINDY website. If you’d like to comment / ask questions head over here:

    http://www.lindy.co.uk/blog/2009/02/04/recording-guitar-in-garageband/

  36. Gary permalink
    May 27, 2010 10:03 pm

    Hi

    I have recently purchased one of these cables and im having a bit of a problem with it. It gives out a strance constant beeping noise, not very loud just in the background like interfearence, ive tried changing input volumes etc but it doesnt seem to do anything. I increased the noise gate level and that gets rid of it while your not playing, but as soon as I start, I can hear it faintly in the background.

    Hope you can help

    Thanks in advance

    G.

  37. May 28, 2010 8:21 am

    Hi Gary

    We’ve stopped using this wordpress blog. So, if you don’t mind I’ve moved your question to our support forum here…

    http://forum.lindy.co.uk/viewtopic.php?f=10&t=71

    I’ve answered it too!

    MikeO

  38. August 22, 2010 2:48 pm

    though the quality of the recording won´t be a killer, you can sure have some fun with this set. Considering buying a pro audio interface isn´t a bad idea. it averages $250 usd nowadays and does it[s job pretty well. I would recommend the ma audio delta 1010 lt.

  39. DonS permalink
    November 16, 2011 10:19 pm

    Has any one tried pluging into an iPad via the camera adaptor kits USB port. I know this works for USB head sets, wondering if would also work for this and what the latency would be like.

  40. November 17, 2011 11:55 am

    I’m not aware of anyone trying this so we’re going to give it a go ourselves, hopefully tomorrow.

    We are actually going to be launching a dedicated iPhone / iPad guitar interface cable soon.

    By the way, we’ve moved this blog so it’s hosted on our website now here:

    http://www.lindy.co.uk/blog/

  41. December 1, 2012 8:18 am

    Wow, this paragraph is pleasant, my sister is analyzing such
    things, thus I am going to tell her.

  42. Princess permalink
    December 21, 2012 9:34 pm

    Hey are using WordPress for your blog platform? I’m new to the blog world but I’m trying to get started and set up my own.
    Do you require any html coding expertise to make your own blog?
    Any help would be really appreciated!

Trackbacks

  1. Lindy Original Bait Tamer Reviews | fishing tackle rods and reels, fishing tackle online, fishing equipment online

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: